Error Compiling v1.9.0 on Ubuntu 9.10

Has anyone tried compiling v1.9.0 on 64 bit Ubuntu 9.10. I installed the MPI compiler, changed the 64bit architecture cc_options in the makefile. The compilation process completes till the end and then terminates right before outputting the mothur executable.

I had no issues compiling v1.8.0 using the C++ compiler earlier. Everything worked well, even readline.

Any suggestions?

Please re-download the source code and give it another whirl. Also note that by default the readline and openMPI libraries are not included in the compilation. Change the flags in the makefile from no to yes (and be sure the libraries are installed).


That does not seem to help. I downloaded the new code and also confirmed that i have the openMPI package installed, but it still gives an error right before the mothur executable.

These are the last few lines of the compilation:
-o …/Release/mothur
/usr/bin/ld: cannot open output file …/Release/mothur: No such file or directory
collect2: ld returned 1 exit status
make: *** [mothur] Error 1

Any suggestions?

Sorry, try replacing the line:
-o …/Release/mothur
-o mothur

I’ll post the update.

I got it to work after making a Release directory at the same level as the Mothur source code. directory. If you are not updating the source code, i can simply edit the wiki for installation for other users…