Dist.seqs - Segmentation fault

Dear all,

hope you are doing well.

After running the dist.seqs command using an edited shared file, Mothur closed automatically after the message “Segmentation fault (core dumped)”
Please notice I’ve edited the respective shared file since I’ve selected specific information for running some statistical analyses in Mothur.
I’ve just sent an email to you with the shared file in attachment.

Thank you in advance.

Hi Allan - you shouldn’t be running dist.seqs on a shared file. Can you try using dist.shared instead?


Hi Pat,
thanks for your feedback.
I’ve just tried it and broke once again.
Same error.
Even considering a transposed file …


Your first six columns look like this…
Screenshot 2024-05-07 at 10.41.35 AM

A shared file needs to have the first column be a label column where every row has the same value. The second column should be what you have as the Group column, the third column should be the number of OTUs in the dataset, which is the number of remaining columns - in your case it would be 35.