mothur

segmentation fault dist.shared

Hi,
I am currently analyzing two datasets. The following occurs only with one of them.
When I run dist.shared (1.39.5), it throws segmentation fault.

dist.shared(shared=h.opti_mcc.shared,output=column,iters=1000,subsample=4000,calc=braycurtis-jclass-jsd-thetayc)

I tried doing the same without iters, without subsampling, removing and adding calculators, changing the number of processors, the results are always the same. I have no idea why this is happening?

this is the end of debug output:

[DEBUG]: OTU7045 0[DEBUG]: OTU7046 0[DEBUG]: OTU7047 0[DEBUG]: OTU7048 1[DEBUG]: OTU7049 0[DEBUG]: OTU7050 0[DEBUG]: OTU7051 00.03
Segmentation fault (core dumped)

It doesn’t help me :slight_smile:

THanks in advance for your help,
L

Could you send your shared file to mothur.bugs@gmail.com?

I am sorry to reply so late, but I solved the problem in the meantime and haven’t noticed this notification.
Anyway, I don’t remember the exact issue :D, but as far as I do, there were reads missing from the groups file. Unfortunately I don’t remember the details and I promise I will document it next time :slight_smile: