align.seqs in mothur 1.13


I am having yet another problem with the version 1.13 of mothur, this time with the align.seqs command. I have about 90,000 pyrotags that I need to do some analysis on. I aligned my sequences using reference SILVA alignment. When I tried to filter the alignment using filter.seqs command, I get the following:

filter.seqs(fasta=TCA_454.qc.noproblem.nochimera.noeurkaryota.fasta, vertical=T)
Creating Filter…
Sequences are not all the same length, please correct.

When I align the sequences using version 1.12 of mothur, I do not get the same error I got when invoking the filter.seqs command. I would like to post an input file for my alignment, but due to the nature of its size, I don’t think I will attach that to this post. What I like to know is, whether there is some reason for such discrepancy. Thank you in advance.


Did you mistype the file name into the filter.seqs command? The align.seqs command would have renamed the aligned file to TCA_454.qc.noproblem.nochimera.noeurkaryota.align.