align.seqs 'Error in reading your fastafile, at position -1'

Hi,

When I run align.seqs using 4 or more processors I get the error: Error in reading your fastafile, at position -1

At first I thought it may be a memory issue, as I am almost maxing out my 16 GB of RAM, but using 2 or 3 processors also appears to use the same amount of RAM as using 4. I was wondering if maybe it’s a thread not being able to access the fasta file instead.

A logfile with the logs from using 1, 2, 3, and 4 processors is available here. I first noticed this when using 8 processors.

The alignment is between the full SILVA v123 reference alignment and a fasta file containing three V45 sequences.

Let me know if you need more information from me.

Thanks for your help,
Richard

Thanks for reporting this bug. We have fixed it for version 1.37 coming soon. The problem stems from the number of sequences being less than the number of processors. Mothur should adjust for this and did, but was +1 on the adjustment. Setting the number of processors <= the number of sequences will resolve the issue.

1 Like

Ah that makes sense. Thanks for fixing this.

Cheers
Richard