After chimera.vsearch, "Error in reading your fastafile, at position -1. Blank name."

Hi,
I’m a PhD student, and I’m using a modified version of the MiSeq SOP to fit my data.

I encountered an error message during the chimera.vsearch step:
Error in reading your fastafile, at position -1. Blank name.

I tried reducing the number of processors (from 16 to 2) and also updated vsearch to the latest version (from 2.27.0 to 2.28.1), but the same error keeps occurring.
I used the latest version (1.48.1) of Mothur, too!

I checked the fasta file used in chimera.vsearch, and there are no blank headers.
I’m not sure where the problem is.

I’m scheduled to attend a conference, so I would appreciate a prompt reply. ㅠ_ㅠ

If there are any other files needed to solve this problem, please let me know the email address to send them to.

Thank you always.
Jiwon from S. Korea

Hi,
I changed the command and tried again, and the issue was resolved.

The command I initially tried was:
chimera.vsearch(vsearch=/home/user12/mothur_config/vsearch-2.28.1-linux-x86_64, fasta=current, count=current, dereplicate=t)

The command I tried again was:
chimera.vsearch(fasta=current, count=current, dereplicate=t)

I hope this helps someone.

Best regards,
Jiwon :slight_smile: