Chimera vsearch error

mothur is helpful and it might be obvious but, sorry, I cannot figure out how to make chimera.vsearch work. Please let me know a solution. My command and output with error message is shown below. I use mothur v.1.48.0.

mothur > chimera.vsearch(fasta=GenBank_prep_subm_16S_test.txt, reference=silva.nr_v138_1.pick_Bacteria.align)

Using 4 processors.
Checking sequences from GenBank_prep_subm_16S_test.txt …
[ERROR]: Could not open GenBank_prep_subm_16S_test.temp
Error in reading your fastafile, at position -1. Blank name.
vsearch v2.16.0_win_x86_64, 7.9GB RAM, 4 cores

Reading file GenBank_prep_subm_16S_test.temp.vsearch_formatted 100%
0 nt in 0 seqs
Masking 100%
Counting k-mers 100%
Creating k-mer index 100%
Detecting chimeras 100%
Found 0 chimeras, 0 non-chimeras,
and 0 borderline sequences in 0 unique sequences.
Taking abundance information into account, this corresponds to
0 chimeras, 0 non-chimeras,
and 0 borderline sequences in 0 total sequences.

Hi there - it looks like you must have the wrong file name or it’s somewhere other than you expect. If you are running mothur on a mac/linux, can you run the following from within mothur?


And if you’re in windows can you run the following from within mothur?


If you can post the output that would be great.


thanks for the help. I use windows and running system(dir) I see the two files. For example: “15.04.2024 17:44 17 967 GenBank_prep_subm_16S_test.txt”. In total listed 805 File(s) and 4 Dir(s). Checking, the command worked with fasta and count file used with chimera.vsearch before. That fasta file with the reference file caused error again. Running filter.seqs on the reference, error again. Changing to reference silva.nr_v138_1.align, still error. Then I just changed the command to using count. Now it worked (no chimeras found). I made the count file (using make.count) from the fasta file and the reference sequences for the phylogenetic tree I place these sequences in.

Can you post the first 10 lines of GenBank_prep_subm_16S_test.txt?


the first 10 lines of that file but not with the “_test” in the filename, is shown below. I had deleted the test file including from the trash. I had cleaned up to remove files from testing and big silva files downloaded to make more space on the hard disk. Having pasted the first 10 lines from the text file into here I deleted all nucleotides following the indicated … Sequences have not been deposited yet. Anyway, I got the same error. I do not understand why it does not work with a reference file but works with a count file.





Can you send the file you are using to and reference this forum thread by including its url? Chimera vsearch error - #4 by pschloss

Hi Sigmund,

I’m not seeing the error you describe…

mothur > chimera.uchime(fasta=silva.nr_v138_1.pick_Bacteria.subsample_5.align, reference=silva.nr_v138_1.pick_Bacteria.subsample_100.align)

Using 1 processors.

uchime by Robert C. Edgar
This code is donated to the public domain.

Checking sequences from silva.nr_v138_1.pick_Bacteria.subsample_5.align …

It took 0 secs to check 5 sequences. 0 chimeras were found.

No chimeras found, skipping remove.seqs.

Output File Names:

I’m still not sure how or what you’re running. If you are using the reference-based chimera checking approach, we strongly recommend using the gold database which you can find here under the link for the chimera.slayer database. But in general, we don’t recommend using the reference-based approach…


error message is from chimera.vsearch (chimera.uchime is fine). Anyway, chimera.vsearch gave no error message with a count file so I feel this is not so important since can be circumvented.

Ah, I didn’t notice that. Can you use chimera.uchime instead? They’re the same method.