mothur

unique.seqs error


#1

When running unique.seqs command, I am getting the error below:

mothur > unique.seqs(fasta=uic.trim.contigs.good.fasta )


[ERROR]: You already have a sequence named M02127_258_000000000-B4RL2_1_1101_16099_2069 in your fasta file, sequence names must be unique, please correct. This error is repeated for all of the sequences that I will not add to this post. This seems odd that this command would require unique sequences.

The details for the mothur version used are:
Linux version
Using ReadLine
Running 64Bit Version
mothur v.1.39.5

Thanks for your assistance,
Stephanie


#2

What are the commands that you are running upstream of this command?


#3

The previous commands were:

make.contigs(file=uic.files, processors=8)

summary.seqs(fasta=current)

screen.seqs(fasta=current, group=current, summary=current, maxambig=0, maxlength=275)

summary.seqs(fasta=current)

get.current()

unique.seqs(fasta=current)
Using uic.trim.contigs.good.fasta as input file for the fasta parameter.

Best,
Stephanie


#4

I also have run these same set of commands on the newest version for Mac using 1 processor, in which I still get the same error, except for only a large subset of sequences, and not every sequence.


#5

Could you have duplicate files in your uic.files file? If not, can you send your input files and log file to mothur.bugs@gmail.com?


#6

I have been getting this same error recently. When I ran my data using v 1.39.5 the error occurred after make.contigs and identified 68 repeated sequence names. However, when I updated to v.1.40.5 the error didn’t occur until the unique.seqs command and identified thousands of repeated sequence names.


Thank you for the help,

Kelsy


#7

Could you send your input files and logfile to mothur.bugs@gmail.com?