unable to open files

Hallo,

I’m totaly new in the mothur environment. I work on mac.
I downloaded alignment of my sequences from ARB and tried to check it. I followed the manual on wiki, but every time I tried I got the message:
Unable to open silva.ss.map
Unable to open klB.fas

then I decided to exercise on esophageal community analysis example given on Wiki and followed the tutorial. I put all files in one folder together with mothur, but this time I was also unsuccessful…

mothur > align.seqs(candidate=esophagus.fasta, template=core_set_aligned.imputed.fasta, processors=2)

Unable to open core_set_aligned.imputed.fasta
Unable to open esophagus.fasta. It will be disregarded.
no valid files.

Can somebody explain me what I am doing wrong?
Thank you very much for help.
Klemi

The most common cause of mothur not finding a file is because you double clicked on the mothur executable to run mothur. This will open a terminal window in your home directory. Mothur will then look for the input files in the home directory instead of in the directory where mothur’s executable is located. If this is the cause, you either put the input files in your home directory, give complete file names, or open a terminal window, cd into the directory where the mothur executable is located and run mothur by using “./mothur”.

1 Like

Hallo,
thank you very much. that was the problem.
I could complete successfully the esophageal community analysis example.

then I tried to analyse my data. I started with alignment
mothur > mothur > align.seqs(candidate=seq250VAC20Okt10.fasta, template=silva.bacteria.fasta)
Reading in the silva.bacteria.fasta template sequences… DONE.
Aligning sequences from seq250VAC20Okt10.fasta …
We’re into F 1065 10
We’re into F 1096 21
We’re into D 1147 42

We’re into F 10196 476
Segmentation fault

three files were written: seq250VAC20Okt10.align, seq250VAC20Okt10.align.report and seq250VAC20Okt10.flip.accnos but I cannot open any of them :-/
mothur > summary.seqs(fasta=seq250VAC20Okt10.align)

[ERROR]: seq250VAC20Okt10.align is blank. Please correct.
Error in reading your fastafile, at position -1. Blank name.
Segmentation fault

I tried to find any information about “Segmentation fault” on the forum, but I couldn’t find anything.

Probably there is something wrong with my fasta file, but I have no idea what…
How should the file look like?

Thank you very much!

When I took a look at your fasta file, I noticed you have spaces in the sequence string. Spaces are not allowed in the sequence string. Could you try removing them and see if you still have any problems?

I am also encountering similar problem.

I am trying to replicate the Costello stool analysis http://www.mothur.org/wiki/Costello_stool_analysis using mothur v 1.17.3 in suse linux.
It shows the following error.

mothur> align.seqs(candidate=stool.trim.unique.fasta, template=silva.bacteria/silva.bacteria.fasta, processors=2)

Reading in the silva.bacteria/silva.bacteria.fasta template sequences...        DONE.
Aligning sequences from stool.trim.unique.fasta ...
100
100
200


[ERROR]: stool.trim.unique.align11024.num.temp is blank. Please correct.
[ERROR]: stool.trim.unique.align11025.num.temp is blank. Please correct.
It took 103 secs to align 0 sequences.

I looked for the spaces, but couldn’t find and moreover its running fine with the same files in the windows system.
Some times it is showing

Segmentation fault

too.

I would appreciate enlightening me about the error and its cause?