Uchime error- could not find .chimerastrim file


I am pretty new to use of Mothur. I installed version 1.45.1 today using source file. I am following “454 SOP” tutorial using one of the pyrosequencing file I have obtained from a previously published study. In chimera removal step, I am constantly getting an error message

Invalid command line
Expected -option_name or --option_name, got ‘ȷ-’
For list of command-line options use --help.
[ERROR]: Could not open /home/eraysahin/Theriot_16s/sff/SRR1047904.shhh.trim.unique.good.filter.unique.precluster.denovo.uchime.chimerastrim

and was not terminating the step. I removed all the mothur installation and analysis outputs, and repeated the steps (because in previous try, I was also getting an error related to uchime itself, it could not be found even though there was no error with make), but could not get rid of the error message above.

I am enclosing a part of the log file after pre clustering step, I have added the error message below the log.

Best regards,


mothur > chimera.uchime(fasta=/home/eraysahin//sff/[file].shhh.trim.unique.good.filter.unique.precluster.fasta, count=/home/eraysahin//sff/[file].shhh.trim.unique.good.filter.unique.precluster.count_table, processors=40)

Using 40 processors.
[DEBUG]: uchime location using /home/eraysahin/tools/mothur-1.45.1/uchime

uchime by Robert C. Edgar
This code is donated to the public domain.

Checking sequences from /home/eraysahin/***/sff/[file].shhh.trim.unique.good.filter.unique.precluster.fasta …

Running command: split.groups(groups=trim, fasta=/home/eraysahin/
/sff/[file].shhh.trim.unique.good.filter.unique.precluster.fasta, count=/home/eraysahin/

Using 40 processors.
Reducing processors to 1.
Running command: get.seqs(dups=f, accnos=/home/eraysahin/
/sff/[file].shhh.trim.unique.good.filter.unique.precluster.trim.count_table.accnos, fasta=/home/eraysahin/
Selected 283 sequences from your fasta file.

Output File Names:


Output File Names:

Reducing processors to 1.

Invalid command line
Expected -option_name or --option_name, got ‘ȷ-’
For list of command-line options use --help.

[ERROR]: Could not open /home/eraysahin/***/sff/[file].shhh.trim.unique.good.filter.unique.precluster.denovo.uchime.chimerastrim

quitting command…
It took 824 secs to check 283 sequences.

Could you set the debug variable and send me the command sent to uchime?

mothur > set.dir(debug=t) - set debug flag

mothur > chimera.uchime(fasta=/home/eraysahin/ /sff/[file].shhh.trim.unique.good.filter.unique.precluster.fasta, count=/home/eraysahin/ /sff/[file].shhh.trim.unique.good.filter.unique.precluster.count_table, processors=40) - run uchime command

In the logfile you should see something like:

[DEBUG]: uchime command = "/Users/swestcott/Desktop/1.45.1/mothur/uchime"  --input "/Users/swestcott/Desktop/release/stability.trim.contigs.good.unique.good.filter.unique.temp12.temp" --uchimeout "/Users/swestcott/Desktop/release/stability.trim.contigs.good.unique.good.filter.unique.denovo.uchime.chimeras12.tempF3D3" .

Do you have uchime installed on your machine? The chimera.uchime command is a wrapper for the uchime program. Mothur uses several external tools including: uchime, vsearch, blast, prefetch and fasters-dump. They are included with the pre-built binaries, or can be downloaded separately. Releases · mothur/mothur · GitHub

Dear @westcott,

Thank you for your reply.

Regarding uchime installation, I have installed Source code folder and run ‘make’. The thing I’ve noticed is that during my first attempts, I was only getting error related to the opening file with extension of .chimerastrim. Later, there was the message below;

Unable to open uchime. Trying mothur’s executable location uchime.
Unable to open uchime. Trying mothur’s tools location uchime.
Unable to open uchime.
uchime file does not exist. Checking path…
Found uchime in your path, using /home/eraysahin/tools/mothur-1.45.1/tools//uchime
uchime by Robert C. Edgar

even though I have puth the path to the bash profile within the same directory as mothur.

For debugging, I uploaded the logfile to dropbox, you can find on Dropbox - mothur.1617795985.logfile - Simplify your life.

I also installed, put path to the bash profile, but got the same problem.

Best regards,


Hello hello

I’ve been using mother in my lab without any change and I too am suddenly having what might be a similar issue with uchime. My guess was that it’s having trouble finding files so I re-downloaded all the files/tools and ran the sequence of commands again and am still stuck at uchime.

I ran the debug as you wrote above - that’s here: [dropbox link]
Unfortunately it appeared to stall - so no extra details from the log report

these are the details from command prompt before the debug:

mothur > chimera.uchime(fasta=trial1sequences.trim.pcr.trim.good.unique.good.filter.unique.precluster.fasta,

Using 4 processors.
[DEBUG]: uchime location using R:\GEOMICRO-A1979\MOTHUR stuff\SAM_MOTHUR\uchime.exe

uchime by Robert C. Edgar
—line removed because of user link restriction
This code is donated to the public domain.

Checking sequences from trial1sequences.trim.pcr.trim.good.unique.good.filter.unique.precluster.fasta …
‘R:\GEOMICRO-A1979\MOTHUR’ is not recognized as an internal or external command,
operable program or batch file.
[ERROR]: Could not open trial1sequences.trim.pcr.trim.good.unique.good.filter.unique.precluster.ref.uchime.chimeras

I hope I’m missing something simple and figure this out by the time it’s read.

Thanks a lot,

dropbox link failed to post

Thanks @eray.sahin and @poitrasj for sharing your log files and helping us resolve this issue. Can you give this version a try, Release Version 1.45.2 · mothur/mothur · GitHub?

Thanks so much @westcott
It’s working

Thanks again,

Dear @westcott,

Thank you for your help, and sorry for my late response.

Today, I’ve tried to download source code of version 1.45.2, and during ‘make’ step, there was an error related to the absence of ‘splitkmerdist.o’. I copied the one in ver. 1.45.1, then got another error, and you can find the log file in the link below.

I will try to use uchime in tools version, but wanted to inform you.

Best regards,

@eray.sahin did you run “make clean”, then “make”? Make clean removes old object files, before you try to recreate them.


Thank you for the suggestion. I did it, but got the error message below;

g++: error: splitkmerdist.o: No such file or directory
make: *** [mothur] Error 1


It looks like there may be an extra copy of the splitkmerdist.hpp and splitkmerdist.cpp in the mothur folder. They are also located in the source folder where they should be. Can you try deleting the extra copies of the files and make clean, then make?

Alternatively, you could download our prebuilt executable for your OS to avoid building from source.

I removed all the source folders, and re-downloaded them but got the same error message indicating the absence of splitkmerdist.o file.
I downloaded the mothur.linux prebuilt but when I attempt to use mothur, I get:

mothur: error while loading shared libraries: cannot open shared object file: No such file or directory

Can you try this version,

Had this;

/home/eraysahin/tools/mothur/mothur: /lib64/ version GLIBC_2.27' not found (required by /home/eraysahin/tools/mothur/mothur) /home/eraysahin/tools/mothur/mothur: /lib64/ version GLIBC_2.23’ not found (required by /home/eraysahin/tools/mothur/mothur)
/home/eraysahin/tools/mothur/mothur: /lib64/ version GLIBCXX_3.4.20' not found (required by /home/eraysahin/tools/mothur/mothur) /home/eraysahin/tools/mothur/mothur: /lib64/ version CXXABI_1.3.8’ not found (required by /home/eraysahin/tools/mothur/mothur)
/home/eraysahin/tools/mothur/mothur: /lib64/ version CXXABI_1.3.9' not found (required by /home/eraysahin/tools/mothur/mothur) /home/eraysahin/tools/mothur/mothur: /lib64/ version GLIBCXX_3.4.22’ not found (required by /home/eraysahin/tools/mothur/mothur)
/home/eraysahin/tools/mothur/mothur: /lib64/ version GLIBCXX_3.4.21' not found (required by /home/eraysahin/tools/mothur/mothur) /home/eraysahin/tools/mothur/mothur: /lib64/ version GLIBC_2.28’ not found (required by /home/eraysahin/tools/mothur/mothur)

Note: I am trying to use it on the server of our group without root privileges.

Thank you so much for your time.

That error is likely due to your OS version. Try this one,

Yes, it worked.

Thank you @westcott so much, I really appreciate for your help and patience.

Best regards,

1 Like