Ubuntu_18 versions 'release date' issue

In executable versions with ‘Ubuntu’ in the title, the release date always returns the current date.
For example, when I type mothur --version , it returns

Mothur version=1.44.3
Release Date=1/9/21

I believe this is a bug. I think it should return Release Date=8/27/20 as it does for the other Linux executable versions.

Thanks for reporting this bug. It will be fixed in our next release.

Hello. I can’t decide if I’m being tormented by a ghost in my computer, or if my dementia is full-blown, or maybe I’m just a regular idiot, but I have been unable to install any version of Mothur in either Linux or Ubuntu varieties that is not v1.39.5. The first version I attempted to install was v1.44.3 which was downloaded from the GitHub page. After using it for several months, I noticed all my logfiles said v1.39.5. I uninstalled, and reinstalled v1.44.3 from GitHub and it still says v1.39.5. I tried to use #sudo apt --purge autoremove mothur and then list installed packages and mothur is gone. I installed v1.44.2 and it says v1.39.5. I uninstalled and tried installing the Linux version of v1.44.3 and (later on) v1.44.2). It always says v1.39.5. I am losing my mind, and there isn’t much left of my mind at this point. Can anyone help? I’ve spent hours on StackOverflow and this apparently is not a problem that actually exists.

I am using an AWS EC2 Ubuntu 18.04 instance and using Putty and WinSCP to connect.

Hi lsteinberg,

It was the same when I firstly installed mothur. I highly recommend you install with anaconda. Please try the command line as I have done so far I am using Ubuntu 20.04.

conda create -n mothur -y

conda install -n mothur -c bioconda -c conda-forge mothur=1.44.1

some conflicts informed that why I used here -c conda-forge .

I can not install successful current updatest version 1.44.3
Hope it helps.

Hi, thanks! I really appreciate the help. I set up a Ubuntu 20.04 instance and successfully installed conda, but I cannot use it yet. I added the executable to my path, but I still get the error $conda: command not found when I try to use it to install Mothur. If you have any thoughts on what could be causing that, I would love to know! Otherwise, it’s going to take me some time to install conda to see if I can use conda to install mothur.

Update: I had to restart my terminal.

For anyone following this gripping saga, someone reported on the GitHub page that he was unable to update to the latest version of Mothur in Ubuntu 18.04 and needed to upgrade to Ubuntu 20.04: Ubuntu update to version 1.44.3? · Issue #759 · mothur/mothur · GitHub

I started a new Ubuntu EC2 instance on AWS, and installed Anaconda with Python3 using:

wget https://repo.continuum.io/archive/Anaconda3-2018.12-Linux-x86_64.sh

Start the guided install of Anaconda by navigating to the file and running:

bash Anaconda3-2018.12-Linux-x86_64.sh

I believe this should add Anaconda to the path, but if not you can use:

export PATH="/home/username/Anaconda3/bin":$PATH

by replacing location in quotes with actual location on your local drive. You may need to close the terminal and restart for conda to be active.

I downloaded the Mothur package and tried to install using:

conda install /path_to_package/

I got an error saying the package could not be located. I then tried to use the information from nvt_1009 above, but got an error saying:

EnvironmentLocationNotFound: not a conda environment

I tried to add conda-forge to the list of channels with this:

conda config --append channels conda-forge

I then tried to install mothur from conda-forge and got the same error:

EnvironmentLocationNotFound: not a conda environment

Still working on this…

I ran…

conda create -n mothur -y

…a second time. Maybe I typed something in incorrectly and the environment wasn’t created. Anyway, I’m up and running! Thank you again nvt_1009!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.