Trim.seqs crash in Windows7 version 1.24


I recently updated to MOTHUR 1.24.1 and have encountered a crash error when running trim.seqs in Windows7, 64-bit. I get a Windows “not responding” error and MOTHUR force quits. I tried running this command on a new data set and on a set that I had analyzed previously with no program errors (previous version of MOTHUR, same machine and OS). I had no crash error when I tried my data set on another computer that had a really old version of MOTHUR (1.15) in Ubuntu.
My exact command string is: mothur > trim.seqs(fasta=Throat.shhh.fasta, name=Throat.shhh.names, oligos=Throat.oligos, pdiffs=2, bdiffs=0, maxhomop=6, minlength=200, flip=T)
This was using my old data set and the batch file that I had written to analyze it previously. Any ideas?

Thank you!

-Kelsea Jewell

Instead of starting another trim.seqs thread, I wanted to add on to this particular issue.

When I run trim.seqs, I’m having mismatches between the fasta and names files. Specifically, sequences are being removed from the names file, but not from the fasta file. I’m also using version 1.24 on a Windows7 machine. Using an older version of mothur alleviated this problem.

Thanks for reporting this issue, it will be fixed in the next release of mothur. In the meantime, if you run trim.seqs with processors=2, it should work.
Could you post the exact command you are running so I can try to track down the problem?

The fasta file-names file mismatch has happened a few times for me as well, in version 1.24.1.

When I open the shhh.trim.names file in a text editor, I see that it contains a large amount of empty space before the names. Presumably, some names are chopped off, but I am not sure why.

The weird thing is that it doesn’t happen every time. For instance, I had three sets of data that I was running through trim.seqs during the same mothur session. The mismatch occurred for two datasets but not the third. The way I got around this problem was by repeating the command as many times as it took to get it right!