trim.seqs all sequences go to scrap with oligos option

I’m having an issue with the trim.seqs command. I have roughly 1400 Sanger sequences of 16S DNA. My goal is to remove the plasmid DNA remnants from each end of my 16S genes. I created an oligos file with the forward sequencing primer (near the EcoR I site of the plasmid) but did not include a reverse primer. I also did not include any barcodes or sequence identifiers. When I ran the command every sequence was placed in the scrap file but I found hundreds of sequences that had the correct forward primer. My oligos file, very simple, looks like this… (tab delimited)


command was this:

trim.seqs(fasta=os01_15.align, oligos=16sp.oligos)

Do I need more in the oligos file to make this command run correctly? Should I be using a different command to trim my sequences?

Unfortunately, mothur is not set up to do what you want. The oligos file looks for sequences to start with the barcode, if a barcode isn’t given, it looks for the sequence to start with the forward primer. By the same toke, if a reverse primer is given, the sequences are expected to end with the reverse primer. We’ve gotten a couple of similar questions lately and so we’ll probably reassess this in one of the next versions. Also, it looks like you are trying to give an aligned file to trim.seqs - trim.seqs only works with unaligned sequences at this point.

I tried the unaligned fasta file then the aligned hoping it would help. Now I know why neither would work. Thanks.