sff.multiple - cannot read the .txt file


I am pretty new to Mothur. I tried to run my pyrosequencing data in mothur in linux system. I created a txt file called “sample1.txt” with the name of SFF file, and the name of oligos file. When I run the sff.multiple command, it said “unable to open sample1.txt”. Does anyone have an idea why this happended?

Thank you so much :expressionless:

This error generally happens if you are in the wrong folder or the files are in the wrong folder. If you type “ls” (without the quotes) at the prompt where you are running mothur from do you see sample1.txt?

No. I put them under the folder of “Mothur”. I wonder if that’s the problem.

I moved the files from “Mothur” folder to the direct folder and run again, it said the “Magic Number is not correct, not a valid .sff file”. What problem do you think it is?

Thank you!

Are you sure your sff file is not corrupted? Whenever we have had a bug report about a problem with the Magic number getting a fresh copy of the sff file from the sequence provider has resolved it. If you don’t think this is the issue, you can email your logfile and input files to mothur.bugs@gmail.com and I will take a look for you.

Could you possibly be using an sfftxt file instead of an sff file? The sff file is in binary format and if you open it in a text editor it should be filled with odd characters. The sfftxt file should look like the following:

Common Header:
Magic Number: 779314790
Version: 0001
Index Offset: 0
Index Length: 0
Number of Reads: 2914802
Header Length: 680
Key Length: 4
Number of Flows: 640
Format Code: 1
Flow Chars: TACG
Key Sequence: TCAG

Run Prefix: 2006_12_20_6_54_36
Region #: 00
XY Location: 355375_1143