Segmentation fault with venn when groups have no shared OTUs


I’m using mothur 1.29 on ubuntu 12.04. The venn command is returning a segmentation fault with one of my shared files, but works fine with other shared files generated exactly the same way from similar data. It looks like the fault is generated when two groups have no shared otus.

In my case, I have three groups, A, B and C. B and C have no shared otus at the ‘unique’ level, but they share otus at the other levels. If I run venn(shared=ABC.shared), I get a segmentation fault. If I run venn(shared=ABC.shared, label=0.03-0.05-etc.), without the ‘unique’ level, it runs fine. If I run venn(shared=ABC.shared, groups=A-B) or venn(shared=ABC.shared, groups=A-C), it also works well. Essentially, it seems to fail if it needs to compare B and C at the ‘unique’ level.

This same shared file works well with other commands (rarefaction.single, collect.single, etc.). The absence of shared otus between B and C is the only explanation I’ve come up with for this fault, but I’d be happy to send along the file if you think the problem lies somewhere else.


P.S. This isn’t urgent, since I can easily work out the venn diagram for that one level.

Thanks for bringing this to our attention. I have fixed it and will be posting version 1.29.1 to the wiki later today.