mothur

Segmentation fault (core dumped) using fastq.info()

Hi,

I am trying to use the fastq.info() command to demultiplex some 16S amplicon sequencing reads.

I downloaded version 1.42.3 version of mothur for linux (Mothur.linux_64.zip).

I ran the following command: fastq.info(file=MY001_info,oligos=MY001_oligos.txt,fasta=F,bdiffs=1). The program runs for a short time but then I get the following error message “Segmentation fault (core dumped)”

I get the same error message whether I use the direct download of mothur or use the anaconda installation.

I ran the command again with the debug flag, and this is the final screen output:

“[DEBUG]: forward findex aligned fragment=TAGCAG-C, barcode=TAGCAGAC, numDiffs=1.
[DEBUG]: forward findex aligned fragment=T-AGCAGCT, barcode=TCAGC-GTT, numDiffs=3.
[DEBUG]: forward findex aligned fragment=—TAGCAGC, barcode=TCATAG-A-C, numDiffs=5.
[DEBUG]: forward findex aligned fragment=TAGCAGCT—, barcode=–TC-GCTACG, numDiffs=7.
[DEBUG]: forward findex aligned fragment=TAGCAGCT—, barcode=–TC-GCTATA, numDiffs=7.
[DEBUG]: reverse rindex aligned fragment=ATCGT-ACG, barcode=A-CGTCTCG, numDiffs=3.
[DEBUG]: reverse rindex aligned fragment=—ATC-G, barcode=ACTATCTG, numDiffs=4.
[DEBUG]: reverse rindex aligned fragment=–A-TCGTAC, barcode=AGAGTC–AC, numDiffs=5.
[DEBUG]: reverse rindex aligned fragment=ATCGTACG, barcode=ATCGTACG, numDiffs=0.
[DEBUG]: reverse rindex aligned fragment=ATCGT-ACG–, barcode=–CGTGA-GTG, numDiffs=6.
[DEBUG]: reverse rindex aligned fragment=ATCG-TACG-, barcode=–CGTTACTA, numDiffs=5.
[DEBUG]: reverse rindex aligned fragment=ATCGTACG—, barcode=–C-TACTATA, numDiffs=7.
[DEBUG]: reverse rindex aligned fragment=ATCGTACG—, barcode=–C-TGCGTGT, numDiffs=7.
[DEBUG]: reverse rindex aligned fragment=—ATCGT, barcode=GACACCGT, numDiffs=4.
[DEBUG]: reverse rindex aligned fragment=-ATCGTACG-, barcode=GATCGT–GT, numDiffs=4.
[DEBUG]: reverse rindex aligned fragment=----ATCGT, barcode=GGATATC-T, numDiffs=5.
[DEBUG]: reverse rindex aligned fragment=ATCGT-ACG—, barcode=—GTCA-GATA, numDiffs=8.
[DEBUG]: reverse rindex aligned fragment=ATCGTACG----, barcode=----TACGAGAC, numDiffs=8.
[DEBUG]: reverse rindex aligned fragment=ATCGTA-CG—, barcode=----TAGCGAGT, numDiffs=8.
[DEBUG]: reverse rindex aligned fragment=–ATCGTACG, barcode=TCATCG-A-G, numDiffs=4.
[DEBUG]: reverse rindex aligned fragment=ATCGTACG–, barcode=-TCG-ACGAG, numDiffs=4.
Segmentation fault (core dumped)”

Is this an error with the program or installation or is this my error in setting up the info.file and oligos.txt?

Thanks for any help you can give,

Alan

Could you send your log file and inputs files to mothur.bugs@gmail.com?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.