Sample names from removed tax summary after remove.lineage?

After using remove.lineage on my taxonomy file, and re-running summary.tax, all columns containing my sample names are gone. Is there a way I can prevent this?

Can you post how you are running the command?
Pat

Of course,

Below is the copy and pasted text from the mothur dialog box for (1) how I am creating the original taxonomy file, and the (2) how I am implementing remove.lineage, and generating the new summary file:

(1)

Windows version
Using Boost
mothur v.1.48.0
Last updated: 5/20/22
by
Patrick D. Schloss

[NOTE]: Setting random seed to 19760620.

Interactive Mode

mothur > remove.lineage(taxonomy=“F:\Mothur Issue Example\allfilesNEW_EC.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.nr_v138_1.wang.taxonomy”, taxon=unknown-chloroplast-Chloroplast-Eukryota-mitochondria-Mitochondria)

Output File Names:
F:\Mothur Issue Example\allfilesNEW_EC.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.nr_v138_1.wang.pick.taxonomy
F:\Mothur Issue Example\allfilesNEW_EC.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.nr_v138_1.wang.accnos

(2)

Windows version

Using Boost
mothur v.1.48.0
Last updated: 5/20/22
by
Patrick D. Schloss

[NOTE]: Setting random seed to 19760620.

Interactive Mode

mothur > summary.tax(taxonomy=“F:\Mothur Issue Example\allfilesNEW_EC.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.nr_v138_1.wang.pick.taxonomy”)

It took 8 secs to create the summary file for 690420 sequences.

Output File Names:
F:\Mothur Issue Example\allfilesNEW_EC.trim.contigs.good.unique.good.filter.unique.precluster.denovo.vsearch.nr_v138_1.wang.pick.tax.summary

I’ve also got two screenshots of each summary file for reference. But can only upload one at a time, please let me know if it is needed. Thanks.

Thanks - the sample names and counts were in the original tax.summary file and were obtained from the count file that you gave to classify.seqs the first time through. You would need to include the count file with remove.lineage and then use the new count and taxonomy files in summary.tax

Pat