running mothur under mpirun


I’ve compiled mothur on 64 bit Ubuntu 10.04 and enabled mpi (I set CC=mpic++ in the makefile.) I am now trying to test whether all is well with running mothur under mpi. I’m running the commands on a single machine, dual core. Running mothur by just typing


on the command line, and then running a command, such as the align.seqs command, I can see a single process running, and it completes, for the sequence set I was using, in about 21 seconds.

If I run mothur using mpirun:

mpirun mothur

and then run the same align.seqs command, I still only see one process, and it completes in 21 seconds.

The above suggests that mpi is not relevant to the above command or that my build is not able to not really mpi enabled.

If I assume the former, can anyone tell me what commands might make use of mpi so that I can test my build of mothur will run as expected under mpirun?




mpirun -np 2 mothur


Thanks for the answer - that one should have been obvious, but somehow I couldn’t see the missing parameter.

In following up on this, and (finally) testing mothur under mpirun on my system, I’m experiencing problems. I’m posting to this board, rather than the bugs board, as it follows on from my earlier question, and I suspect myself more than your program for this problem at the moment.

The mothur programs appear to be running fine if I run them directly on the command line. However, when running under mpirun, if I type:

mpirun -np 2 mothur

Mothur starts up, but gives an odd double prompt in version 1.12:

mothur > mothur >

and in version 1.11, I see:

mothur > mothur > 1 is here quit

If I run a simple command, say, reverse.seqs(fasta=xxx.fasta), then in version 1.12, it just hangs (nothing comes to stdout).
For version 1.11, I see the following on screen:

mothur > mothur > 1 is here quit

0 is here reverse.seqs

In both cases, a log file is created, which tells me I ran the reverse.seqs command, but that’s about it. I include the last few lines of the log file below.

Any clues?

( I am working on Ubuntu 10.014. Both versions used the following compiler options in the make file: -O3 -mtune=native -march=native -m64
Both versions had mpi compilation enabled.)



#############last few lines of one of the log files
Type ‘help()’ for information on the commands that are available

Type ‘quit()’ to exit program
Using MPI version 2.2
Interactive Mode

mothur > reverse.seqs(fasta=top3seqs.fasta)

Thanks for bringing this to our attention. We will be releasing a 1.12.1 later today to fix this and a few other bugs that have been brought to our attention.