Running Mothur.Gui through a computer cluster HUB


I am trying to run mothur through a computing cluster network that is offered in our university to facilitate large data analysis work. I have the motherGUI is installed on in the cluster and and have all my data within the same folder in the cluster. I am able to open the mothurGUI but whenever i try running any step it keeps giving me the following exception.cannot run program “/users/sarahwestcott/Desktop/1.32.0/mothurGUI/mothur/mothur”.java.10.10exception:error2.No such file hasoccured in mothur error function.
I have indicated the location of Mothur executable is but its still not working. If i could figure out how to run Mothur on the computing network cluster it would make the process go faster.

Thanks for reporting this issue. That is definitely a bug in 1.32.0. Can you try our current version 1.33.0?

Thanks I will try that.

So I tried the latest version of Linux MothurGUI but I still had the same error…on loading the GUI, the first error I get is: exception: Error 13 permission denied has occurred in mothur function get mothur commandfile, please contact Pat Schloss at…
If i ignore this and go ahead and try to run any command, I then get the same error I have been getting before- exception.cannot run program “/users/sarahwestcott/Desktop/1.32.0/mothurGUI/mothur/mothur”.java.10.10exception:error2.No such file has occured in mothur runner function.
I am new to the Linux system and all but on looking aroung the mothur wiki I figured the error must be due to a failure in accessing the readline. A solution to this I saw was downloading mothur from the source code. I am not sure about this but it looks like there is no source code link for the GUI version. It looks like I will have to settle for using the executable version of mothur on linux which is not a big deal but would have loved to use the GUI…I am just not code friendly but slowly learning to be more familiar with using command line programs… :slight_smile: