mothur

Problem with screen.seqs parameter 'minsim'

Hello!

I am new to posting here so apologies in advance if it’s a mess of a question!

Within the function below, the minsim parameter is not working and seems to be filtering wrong (?). Having it set to 90 removes all my sequences. I have tried changing this parameter to a decimal (minsim=0.90), as that is how the similarity to template sequence result appears in the align.report file, but still too many reads are disappearing as almost all of them are above 90% similarity to the template sequence (and this has not been an issue before). The similarity score from align.seqs is not in decimal form, but it is in screen.seqs - could this be part of the issue/a bug?

screen.seqs(fasta=x.trim.contigs.good.align, alignreport=x.trim.contigs.good.align.report, minsim=90, minscore=10, group=x.contigs.good.groups)

I am using Mothur with ITS2 sequences, and have not previously encountered this problem. Other than coding a workaround or removing the minsim parameter entirely, I’m not sure how to solve this.

Thank you in advance! :slight_smile:

Thanks for reporting this bug. It originated in the align.seqs command. The align.seqs command was not printing the alignment method column in the align.report file. This omission caused the reading of the align report file to fail in screen.seqs, resulting in all reads being removed. This will be fixed in our next release.

In the meantime, you can work around it by adding the column manually. To do so, open the *align.report file in excel, and fill the ‘AlignmentMethod’ column with ‘needleman’. Sorry for the inconvenience.

Ah that makes sense! Thank you for the work around!!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.