pre.cluster error: removing group


With the command mothur > pre.cluster(fasta=merge.good.filter.unique.fasta, count=merge.good.filter.count_table, diffs=2, processors=40) for my 89 samples I’ve obtained the next error for 2 of my samples

Removing group: 2_JOUE_R1 because all sequences have been removed.

Removing group: 2_NEZ_R1 because all sequences have been removed.

And finally I have output files for 87 samples


Why 2 groups had been removed? How I can recuperate these groups?

What version of mothur are you using?

mothur v.1.33.3
Last updated: 4/4/2014

And now, when I’ve made the next step to mothur > chimera.uchime(fasta=merge.good.filter.unique.precluster.fasta, count=merge.good.filter.unique.precluster.count_table, dereplicate=t, processors=40)

I’ve still lost 14 group!!

With our current version, 1.34, I am not seeing any groups removed even when I tried to force it with diffs=200. Could you try the latest version?


I’d tried with the latest version v1.34 but I have the same problem with diff=2; I had modified diff with 0 and 20 values but I have the same problem.

Could you send your input files and log file to

Ok!!!It’s done!

Thank you so much!

Hi Rocio,
This is where the problem is stemming from:

5.5 mothur “#count.seqs(name=merge.names, group=merge.groups)”
Output files: merge.count_table
#error messages here, check the log
#count.seqs() will generate a file called stability.trim.contigs.good.count_table.
#In subsequent commands we’ll use it by using the count option

The error messages you are getting are because your group file only contains the unique sequences. When you run the command before this it must be on fasta files that contain all your sequences, i.e. before you run the unique.seqs command on each individual fasta file.


1 Like