Pcr.seqs generates empty files with used primers

Hi, I’ve tried to trim Silva db v.132 ( which size ~10 Gb) by primers pair:


I made the reverse compliment of the reverse primer and generated file oligos.txt which looks like:


And run mothur with the following commands:

pcr.seqs(fasta=silva.nr_v132.align, oligos=oligos.txt)


pcr.seqs(fasta=silva.nr_v132.align, oligos=oligos.txt, pdiffs=2, rdiffs=2)

In both case pcr.seqs() returned an empty file “silva.nr_v132.pcr.align” and file “silva.nr_v132.scrap.pcr.align” with the same size like the original silva.nr_v132.align file.

After that I’ve tried to repeat this manipulations with Silva SEED db, but result was the same.

And one more, I also tried to reproduce the example from the topic and got the same result which I’ve described - empty *pcr.align file.

mothur version is 1.41.1 (linux)

What I’m doing wrong?


Hi Andrew,

I haven´t used the oligos parameter when creating my custom databases, but maybe the primers are not recognized because of the ambiguities and then all sequences are put into the scrap file (because the database sequences do not contain a M or W)?

I would follow the example given in the SOP and blog post you mentioned. Instead of using an oligo file in the pcr.seqs command, localize where your primers are in the SILVA alignments and use the start & end parameters in pcr.seqs. This works for me at least.

Good luck,


Hi, Rene!

Thanks, I’ll try it as you suggested.

Mothur is able to process ambiguities within the primers, so the M and W are fine. I am wondering if you have incorrect primers?


I can run it with the above oligos file definition.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.