pcr.seqs - ERROR: name mismatch

Hi mothur team,

I may have run into a small bug.

I recently generated error messages from pcr.seqs command with silva.nr_v123.align and oligos files with multiple processors (> 8) on the latest linux version of mothur (v1.37.4).

Initially, I had no issue with 8 processors. Since I generated the error messages from a pcr.seqs command that used 16 processors, mothur kept outputting the same error messages over and over (no matter how I set up the processor option).

I suspected some problem with the output fasta file. But, when I ran a summary.seqs command with it, the statistics looked perfectly fine regardless of how many processors I used.

Surprisingly, quitting mothur and re-running the same command didn’t suppress the error messages even with a single processor. It seems to me that these messages have been chronically activated somehow (perhaps since I first saw the error messages with 16 processors).

Any ideas?


I would be happy to help. Could you send your input file and log file to mothur.bugs@gmail.com?