Parsimony without progress


I’m running the parsimony() command on a tree generated by clearcut. I know that the tree file is ok coz it was used to calculate unifrac distances, I also opened it with FigTree and it seems fine. However, when attempting to run the parsimony command nothing happens. the screen shows:
mothur >
parsimony(tree=Biostim.subsample025.phylip.tre, count=Biostim.subsample025.count_table, groups=all, processors=4)

Using 4 processors.
Comparing to random:|

and remains this way for hours. CPU usage seems too low to indicate that anything is happening. I also tried to change the no. of processors, limit the groups to two out of the 11 I have, to no avail.

Any ideas?



The problem is probably that parsimony is trying to calculate the P-value, which requires doing 1000’s of iterations. I think we’ve turned that off by default with the unifrac commands. So you either sit and wait, reduce the number of iterations, or just skip the command.



Thanks for the reply, however, sitting and waiting did not pay-up. The program shut down by itself after nearly two days, without a trace of parsimony ever taking place in the LOGFILE. I tried before decreasing iterations to 500, without any result.


Can you try 2 iterations and see what happens? Also, FWIW, there are better and faster ways of doing this such as AMOVA or HOMOVA.