opticlust w/fasta rather than dist

What kind of alignment does cluster do if you use method opticlust but just give it fasta rather than a dist file? Needleman? what kind of gap penalties?

It should complain. cluster will only take a distance matrix, not a fasta file.


Here’s what it it said. Is the warning saying that it switched to vsearch? but the output says opti?

mothur > cluster(fasta=RedRootMicrobiomeFung.trim.contigs.good.good.unique.precluster.pick.pick.fasta, count=RedRootMicrobiomeFung.trim.contigs.good.good.unique.precluster.pick.pick.count_table, cutoff=0.05, processors=32)

Using 32 processors.
[NOTE]: Default clustering method has changed to opti. To use average neighbor, set method=average.
[WARNING]: You can only use the processors option when using the agc or dgc clustering methods. Using 1 processor.
./isg/shared/apps/mothur/1.39.4/mothurvsearch file does not exist. Checking path... 
Found vsearch in your path, using /isg/shared/apps/mothur/1.39.4/vsearch
It took 48 seconds to cluster

Output File Names: 

The clustering tag is incorrect and mothur should have aborted when you tried to cluster using the opti method without a distance matrix. I have corrected this and the change will be part of the next release. When you provide a fasta file, mothur can only use the agc and dgc methods to cluster.

Hi Sarah

Rather than abort, can you have it default to agc and print that tag?