mothur

No data in the output of corr.axes command

I am running the corr.axes command with a nmds.axes file and a metadata file. I have 3 set of data to run this command. One set of data works fine. However, for the other two, after running corr.axes command, when I opened the output “metadata.spearman.corr.axes” file, there was no data in it, only the first row was there, as “Feature axis1 p-value axie2 p-value length”.

I used exactly same command for the 3 set of data, 1 works fine, but the other two output empty results. Do not know what happened.

Thanks for the suggestions and helps ahead of time.

If you look at the three data files (nmds.axes?) how do they differ?

Thank you for your response.
I analyzed all the data together, since the beginning, because they belong to one project.
Since “dist.shared” command, I used “groups=” argument to develop 3 different dist files, and I manually add “.A”, “.B”, and “.C” amid the dist file names, to distinguish them.
So, I have 3 different dist files to get 3 different nmds.axes files. Everything is fine by here.
I also have 3 different metadata files. So I tried to run 3 corr.axes command with paird nmds.axes file and metadata file, but only one group worked. The other two produced empty corr.axes files.

Thank you.

Could you email the files to mothur.bugs@gmail.com and reference this thread in your email?

Thanks,

Pat

Yes, I will.

Thank you.

My problem was solved by Sarah. Thanks her.

The issue is caused by the metadata file. I had columns with all 0s.
I need to remove those columns before running.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.