Mismatch error when removing chimeras


I have been running into a problem while processing my 16S Ion Torrent data.

My current protocol consists of the follow:



get.seqs(accnos=current, fasta=current)

make.group(fasta=current, group=A-B-C) - In total i have 16 different groups


screen.seqs(fasta=current, group=current, minlength=200, maxlength=400)



count.seqs(name=current, group=current)

summary.seqs(fasta=current, count=current)
# of unique seqs = 1505791
# of total seqs = 7414979

align.seqs(fasta=current, template=Silva.132.align)

summary.seqs(fasta=current, count=current)

screen.seqs(fasta=current, count=current, summary=current, optimize=start-end, criteria=90)

summary.seqs(fasta=current, count=current)

filter.seqs(fasta=current, vertical=T, trump=.)

unique.seqs(fasta=current, count=current)

summary.seqs(fasta=current, count=current)
# of unique seqs = 599748
# of total seqs = 6130849

pre.cluster(fasta=current, count=current, diffs=2)

chimera.uchime(fasta=current, count=current, dereplicate=t)
remove.seqs(fasta=current, accnos=current, count=current)

At this point I receive the following error:

Removed 29078 sequences from your fasta file.
[ERROR]: G4U8H_00005_00581 is not in your count table. Please correct.

I am currently using mothur version 1.43.0 and uchime version 4.2.40 in Ubuntu 18.04.1 LTS

Any assistance would be much appreciated.


Could you send your logfile and input files to mothur.bugs@gmail.com so I can take a closer look?

Hi Tamar,

Thanks for sending your files. The issue is the combination of chimera.uchime with dereplicate=t and remove.seqs with the count table included. If the dereplicate parameter is false, then if one group finds the sequence to be chimeric, then all groups find it to be chimeric. If you set dereplicate=t, if a group finds a sequence to be chimeric it is only removed from that group. When dereplicate=t mothur creates a modified count file with the chimeric reads removed for you. You do not want to include the modified count file with the remove.seqs command. Instead try this:

mothur > chimera.uchime(fasta=current, count=current, dereplicate=t) - remove chimeras from count table and create accnos file for removing them from other files

mothur > remove.seqs(fasta=current, accnos=current) - remove chimeras from the fasta file


Sarah Westcott

Hi Sarah,

Thanks for your help it worked a treat.



This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.