make.sra from fastq and sff


I am currently trying to make.sra files from both Illumina MiSeq 16S data and from 454 ITS data (separately). A few questions have come up.

For the fastq files from the MiSeq 16S data:
I first tried to make a new fastq file from the contigs I’d made with make.contigs and my forward and reverse fastq files (with reverse complement oligos):

make.fastq(fasta=Reads_R1.trim.contigs.fasta, qfile=Reads_R1.trim.contigs.qual)
but this
make.sra(fastq=Reads_R1.trim_trial.contigs.fastq, oligos=oligos_16SMiSeqv3.oligos, project=test.project, mimark=MiMarksReads_R1contigs.txt, platform=ILLUMNA, instrument=Illumina_MiSeq, includescrap=FALSE)
put everything in scrap. I also tried different versions of the oligos (i.e. not reverse complement) and calling orientation=reverse, but this didn’t work either–everything still ended up in scrap.
Then I tried to use a file that specified the reverse and forward fastq with the same reverse complement oligos that I used in make.contigs:
make.sra(file=trialFandR.file, oligos=oligos_16SMiSeqv3.oligos, project=test.project, mimark=MiMarksReads_R1contigs.txt, platform=ILLUMINA, instrument=Illmina_MiSeq, includescrap=FALSE, pdiffs=2, bdiffs=1)
This seemed to work, slowly, but produced a new fastq file for forward and for reverse for every sample. It did not appear to scrap everything, but it did also did not process all the samples and specifically ended with supposed output files:
Output File Names:
I weirdly cannot find these output files that make.sra has supposedly made.
and the command also ends with errors like:
[ERROR]: MIMarks file is missing group Az_T165_526_AGGCTGATTTGC, please correct.
My MiMarks file has group names (sample IDs) without the associated barcode obtained from get.mimarkspackage (e.g., Az_T165_526), is this not correct?

For the sff files from the 454 ITS data, I am not getting an errors but am having similar problems finding the output files, which I believe as a .fasta and .qual file for each sample were also already made when I originally ran sff.multiple to analyze the data? (What I am finding is the files of same name that I created in February 2015 when I began this analysis, and maybe I can just use those for the SRA data submission anyway.)

Sorry so much confusion, thanks for your help,

First, the quality file created by make.contigs cannot be compared with the quality scores coming off the sequencing machine, The make.sra command is designed to take the raw fastq files or sff files you would enter into make.contigs or sffinfo commands. This would include index files if you used them. You can use the file parameter to make sure all your files are included properly.

One other thing to note, is the get.mimarkspackage command and make.sra command are designed to work together. We have made a few modifications since their initial introduction. These can cause issues if you created the mimark file with one version of mothur and then run the make.sra file with another. This may be the cause of the missing group error.