Issue with count table from make.contig - missing groups


I have an issue with my count table, I can’t retrieve the groups

when I make contigs

make.contigs(ffastq=run2_S1_L001_R1_001.fastq, rfastq=run2_S1_L001_R2_001.fastq, oligos=oligo3.txt, bdiffs=1, checkorient=t)

oligo file

barcode ATGGAA TCGTAG O_A_M_8_9-rep1
barcode ATGGGA TCGTAG O_A_M_8_9-rep1
barcode ATGGTA TCGTAG O_A_M_8_9-rep1
barcode TTTCAG TCGTAG O_HAC_NC_10_4-rep1
barcode AAAGAA TCGTAG O_G_M_6_28-rep1
barcode AGAAGG TCGTAG O_HAM_NC_8_23-rep1
barcode CGCGAG TCGTAG O_HAC_M_5_17-rep1

I get a count per group

O_HO_M_5_3-rep1 12664
O_HO_M_5_31-rep1 47972
O_HO_M_8_23-rep1 15866
O_HO_M_9_20-rep1 25827
O_HO_M_9_6-rep1 69916
O_HO_NC_5_17-rep1 4420
O_HO_NC_5_31-rep1 3082
O_HO_NC_6_14-rep1 4220
O_HO_NC_6_28-rep1 3625
O_HO_NC_7_12-rep1 3347
O_HU_M_6_28-rep1 82515
O_HU_M_7_12-rep1 46536
O_HU_M_7_26-rep1 20600

but when I run on the count table I got a single group with all the contigs

O_A_M_10_4_rep1 contains 11933910.

What is the issue?


Pb solved: there were ‘-’ in several group names and even though it was said that it was replaced with ‘_’ at the end of make.contigs, somehow it made the count table fail.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.