I need help creating an .oligos file for pcr.seqs

I’m basically trying to follow this guide: http://blog.mothur.org/2016/07/07/Customization-for-your-region/

I’ve downloaded the 16S sequence for E.coli from NCBI and saved it as a fasta file. Then I created a text document called “Myoligos” that looks like this;


However when I run this:

pcr.seqs(fasta=ecoli.fasta, oligos=Myoligos.oligos)

I get:
Unable to open Myoligos.oligos. Trying default /usr/bin/mothur/Myoligos.oligos
Unable to open /usr/bin/mothur/Myoligos.oligos. Trying mothur’s location /usr/bin/mothurMyoligos.oligos
Unable to open /usr/bin/mothurMyoligos.oligos

Using 1 processors.
[ERROR]: You did not set any options. Please provide an oligos or ecoli file, or set start or end.
[ERROR]: Invalid start value.
[ERROR]: did not complete pcr.seqs.

How do I fix it? What am I doing wrong? I’ve exited mothur then navigated to my files directory then restarted it and tried to use set.dir but they don’t seem to work.

Hi Anita,

If you go to your terminal and type ls Myoligos.oligos what do you get for output? I suspect you’ll get an error message there as well. If you do, then that’s a sign that the file either isn’t where you think it is or that it has a different name.


Thanks so much. Turns out I had to give Ubuntu permission to use the file (chmod 777).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.