Problem with oligos file

I am unable to trim sequences. Its always giving me the same error: " Unable to open C1O2.oligos file". My file looks like this:

barcode AAAAAATA C1
barcode AAAAAACT O2

Any suggestions!

Thanks Nazia

It could be the primer seq or barcode seq you have entered is incorrect. Here is a simple way of finding out exactly what you barcode seq is (assuming the correct primer seq is known)…

  1. Open up the SAMPLE.fasta file using notepad and enter in the find box (ctrl+f) the forward primer sequence
    -the forward primer sequence should be known (if not supplied then google search the primer name)
  2. The sequence to the left (of what should be a highlighted forward primer sequence) is the barcode and should be present on every sequence in that sample.
  3. In a new notepad, enter in the information in the same way you did before

Hope this helps,


Is the oligos file in the same location as the other files? Can you try providing the full path and see if the issue is resolved? The error indicates mothur is not able to find the file.

Incidentally, those are awful barcode sequences! Remember that 454 gags on homopolymers so having 6 A’s in a row is asking for artificial insertions and deletions.

Thank you all for the suggestions! Actually, I was giving the wrong extension for it …did with .txt and it worked.
About awful barcode, I do not have control over that as we sent our samples to pyrosequencing service lab…I will inquire about it…

Something tells me you are using the same lab for sequencing as I do. They don’t actually use those barcodes, but edit them in after the fact. If you open up the sff files you can see the actual barcode sequences. I’m not sure why they do this.

However, when I extract the sff files myself using mothur and then use trim.seqs, I lose a lot of the sequences (more than half from 136,000 seqs). When I use the fasta and .qual files provided by the seq lab, I don’t lose nearly as many (only a few thousand). Either the Roche sff extract cleans them up or there is some post processing going on.