Help while running get.groups command

Dear Sir,
I am a new user of Mothur software. I stuck at one point while running the
programme MiSeq_SOP. I am not able to done troubleshooting and could not
find where I am doing a mistake. I am pasting the programme file which I am
using while running

mothur >
[NOTE]: The count file should contain only unique names, so mothur assumes
your fasta, list and taxonomy files also contain only uniques.

Mock is not a valid group, and will be disregarded.
You provided no valid groups. I will run the command using all the groups
in your file.
Selected 1507 sequences from your fasta file.
Selected 118828 sequences from your count file.

Output File names:



I am not able to sort out how to put valid Mock group. Please help me.
Thanking you.

Hi there,

Are you using the example data or your own data? If you are using your own data, then you need to generate your own mock community data and make sure you have a sample called “Mock” (or whatever you call it) in the *files file that is used as input to make.contigs.


Thanks Pschloss.
I am using the MiSeq_SOP data. I am not able to make group such as F3D0, F3D1 and so on. I tried to make individual make.file for each group and make there individual contigs. Using make,group command to I tried to make group but fail to do so. I used this command to

mothur >, groups=A-B-C), groups=F3DO-F3D1-F3D2-F3D3, outputdir=stability.files)

Am i doing the right way to make the group file???. If not please suggest me how to make that.


I am not able to make group such as F3D0, F3D1 and so on

Why? You should be able to either use a files file or oligos file to run make.contigs. Regardless, to your original question, you don’t seem to have a group named mock so you can’t do that analysis.


Thanks Pschloss.