mothur

Forward reads for ITS

Hi everyone,

This is my first time using the mothur forum for help. I am currently trying to get my bbduk trimmed ITS data to run through mothur however it keeps timing out. Can anyone help me with the batch file or let me know if there is something wrong with it? I’m not sure what to do. Here is my batch:

summary.seqs(fasta=ITS.clean.merged.fasta, processors=32)

count.seqs(name=ITS.clean.merged.names)

screen.seqs(fasta=ITS.clean.merged.fasta, group=merge.groups, maxambig=0, maxhomop=32)

trim.seqs(fasta=ITS.clean.merged.fasta, qfile=ITS.clean.merged.qual, maxambig=0, maxhomop=12, qaverage=25, processors=32)

list.seqs(fasta=ITS.clean.merged.fasta)

get.seqs(accnos=ITS.clean.merged.accnos, group=merge.groups)

summary.seqs(fasta=ITS.clean.merged.fasta, processors=32)

unique.seqs()

count.seqs(name=current, group=merge.groups)

pre.cluster(fasta=current, count=current, diffs=2)

chimera.uchime(fasta=current, count=current, dereplicate=t)

remove.seqs(fasta=current, accnos=current)

classify.seqs(fasta=current, count=current, reference=/home/hamil689/shared/programs/mothur/databases/UNITE_public_mothur_04.02.2020.fasta, taxonomy=/home/hamil689/shared/programs/mothur/databases/UNITE_public_mothur_04.02.2020_taxonomy.txt, cutoff=60)

remove.lineage(fasta=current, count=current, taxonomy=current, taxon=k__Plantae-k__Protista-k__Protozoa-k__phiX174-unknown)

cluster(fasta=current, name=current, method=agc)

list.seqs(list=current)

get.seqs(accnos=current, group=current, name=current, fasta=current, taxonomy=current)

make.shared(list=current, group=current, label=0.03)

classify.otu(list=current, name=current, taxonomy=current, label=0.03)

make.biom(shared=current, constaxonomy=current)

dist.seqs(fasta=current, output=lt, processors=32)

count.groups(shared=current)

collect.single(shared=current, calc=chao-invsimpson, freq=100)

rarefaction.single(shared=current, calc=sobs, freq=100, processors=32)

summary.single(shared=current, calc=nseqs-coverage-sobs-invsimpson)

dist.shared(shared=current)

heatmap.bin(shared=current, scale=log2, numotu=100)

heatmap.sim(shared=current, calc=jclass-thetayc)

tree.shared(phylip=current)

pcoa(phylip=current)

nmds(phylip=current, mindim=3, maxdim=3)

Hi there,

Where in the pipeline is it timing out? You could always break the pipeline up into multiple batch scripts so that each script only runs part of the pipeline.

Pat

1 Like

Hi Pat,

Thanks for getting back to me so quickly. The batch job runs to the “remove.lineage” step and then goes into the next command of “remove.seqs” where it just stops with the last output file generated named “ITS.clean.merged.unique.precluster.pick.pick.fasta”. I think that splitting the job up into two batch files might be a good way to trouble shoot this. Would the split batch file just start at the remove.lineage step with the file paths put into the code rather than using “current”?

Best,

Right- that’s the downside - you’d have to repopulate all of the the “current” values
Pat

Alright, I tried running a different batch file starting with the “cluster(fasta=…)” step and it just keeps timing out. To trouble shoot this step, I worked interactively in Mothur. Unfortunately, I get this error and I do not understand what’s going on.

I think that I understand that there is a sequence that occurs several times in the count_table - rendering the file non-unique. However, the issue I am confused about is how to remove the representative sequence name that is not unique. My approach was to identify the step where the count _table was made which was in the get.seqs step. But, from there I’m not sure how to fix the step. Do you have any suggestions?

The screen output indicates mothur can’t find the vsearch executable which is required for the agc method. The vsearch executable needs to be in the same location as the mothur executable or in your path. There also seems to be some issues with the input files for the cluster command. Can you send the input files and logfile to mothur.bugs@gmail.com?

1 Like

Hi Westcott,

Thanks for getting back to me. I sent the fasta, count_table, and the log files to the email. Please, let me know if there are any other files you would like me to send. As for the first error, I realized that the vsearch error was because I didn’t update my .bashrc to direct the interactive run to my specific copy of the mothur program.

Best,