mothur

Error: your sequences are not the same length

Hi,

I have classified my reads with classify.seq() and that seems to have worked well, but when I try to pass my fasta file to dist.seq() to obtain an OTU table, I get the error “your sequences are not the same length, aborting”.

I found the same error on this forum, but there was no solution posted.
I have 16S Nanopore data, so possibly my error is caused by that?

Do I need to align the data before using dist.seq()? Because when I align it to my reference database, and then proceed with classify.seq(), the classification does not work anymore.

Best regards,
Luna van der Loos

Hi - yes, the sequences must be aligned prior to running dist.seqs. I’m not sure why classify.seqs isn’t working for you. It shouldn’t matter whether the sequences are aligned or not to run classify.seqs. I would suggest more or less following the MiSeq SOP instructions. If you’re doing this and still running in to problems, can you post the commands you are running before classify.seqs along with the syntax you are using for classify.seqs?