[ERROR} Your count table contains more than 1 sequence named

Hello Pat and mothur community,
I am using mothur v.1.48 for linux. The following command:
make.shared(list=exp43.trim.contigs.subsample.unique.good.filter.unique.precluster.opti_mcc.list, count=exp43.trim.contigs.subsample.unique.good.filter.unique.precluster.count_table)

generates this error:
[ERROR]: Your count table contains more than 1 sequence named #1,exp43_b1m1_060223, sequence names must be unique. Please correct.

If I use the same input files in Windows (mothur v.1.48) I get no error. In linux the count files generates a similar error if input into a different command, say, summary.seqs together with matching fasta file

[ERROR]: Your count table contains more than 1 sequence named Representative_Sequence, sequence names must be unique. Please correct.

I ran into the same error and reported it last year on 9/2/22 running v.1.36.1. Sara assumed it was a bug and said it would be fixed. I have since run similar pipelines, including make.shared command without encountering this issue.

thank you,


Hi there - are you positive you are using 1.48 on linux? When you look at the mothur logfile that is generated from running linux, do you see 1.48 there? It looks like it’s getting tripped up by the newer count_table formatting so I asked about the version number. Could you maybe try using the argument in count.seqs that generates the older version of the files?


Hi Pat, here is the version I’m running:
Linux version

Using ReadLine,Boost,HDF5,GSL
mothur v.1.48.0
Last updated: 5/20/22
Patrick D. Schloss

Department of Microbiology & Immunology

University of Michigan

When using, please cite:
Schloss, P.D., et al., Introducing mothur: Open-source, platform-independent, community-supported software for describing and comparing microbial communities. Appl Environ Microbiol, 2009. 75(23):7537-41.

Distributed under the GNU General Public License

Type ‘help()’ for information on the commands that are available

For questions and analysis support, please visit our forum at https://forum.mothur.org

Type ‘quit()’ to exit program

[NOTE]: Setting random seed to 19760620.

Sorry, I don’t understand what you mean by generating the older version of the files. v.1.48.0 is the only version I have.


Can you try using compress=F with count.seqs?

It ran fine with and without compress argument:
mothur > count.seqs(count=exp43.trim.contigs.subsample.unique.good.filter.unique.precluster.count_table, compress=F)

Output File Names:

mothur > count.seqs(count=exp43.trim.contigs.subsample.unique.good.filter.unique.precluster.count_table)

Output File Names:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.