"error" on "remove. seq." command

Hi everyone,

I can’t run the " remove. seq". command on Mothur v1.37.6 (amazon), what is the problem?
Can anyone give me some suggestion?


Many thanks,


Hi Suyan,

It looks like there are problems with the data you put into chimera.uchime. See the error about having short sequences. It appears that you have sequences in the dataset that are shorter than 9 nt long. By the time you get to remove.seqs nothing has been flaggged as chimeric and so there’s nothing to remove. You should go back to the beginning and see why you have such short sequences and why this sample only has 3 sequences.

I’d also suggest upgrading the version of mothur you are using to 1.42.3. The version you are using is a couple of years old at this point.


Hi Pat,

Thanks for your advice, I will try new one.



Hi Pat,

I still run the Mothur with the old version of 1.37.6 on Amzon AMI for my sequencing data analysis, since the other supplied new version cannot be run well.

I have the following problem as I run version 1.37.6 Mothur:

After I run the command
align. seqs(),
NBases strangely decreased from 500 to 2 and the error is described like
“ Some of your sequences generated alignments that eliminated too many bases, a list is provided in data/raw/stability.trim.contigs.good.unique.flip.accnos.
If you set the flip parameter to true mothur will try aligning the reverse compliment as well
”. Then, I tried to set the flip=T, and threshold=0.75, but I got the same error. What should I do for that ?

This old version is still popular now since I found in newest published paper many people could successfully process their data by this version. Thus, there may be something I have not considered.
The logfile is attached, would you please have a look and give me some suggestions to solve the problem?

Kind regards,


(Attachment mothur.Su.logfile is missing)


You really should upgrade to 1.42.3. Can you post the output from running summary.seqs on the output of running align.seqs on your data?