mothur

Dist.shared with subsampling hangs in 1.41.3

#1

Hi, I’m a new user of mothur and I’m trying to run the following using Ubuntu 18.04:

dist.shared (shared = my.shared, calc = thetayc - jclass, sumbsample = 3648, processors = 10)

This is taking 15+ hours to complete, so I’m assuming it’s hanging.

However, if I run sub.sample(shared = my.shared, size = 3648)
then
dist.shared (shared = my.0.03.subsample.shared, calc = thetayc - jclass, processors = 10)
this works fine. Is this a known issue / appropriate work around?

Thanks

#2

Hi,

No that is not an appropriate work-around. Running sub.sample and then dist.shared is the same as running dist.shared with iters=1. You might try running the original dist.shared function call with iters=100.

How many samples do you have and how many OTUs are there? Is anything outputted to the screen?

pat

#3

Hi Pat,

I have 50 samples. I have one sample with 106 OTUs and the rest range from 3648 to approx 40000. The only output to the screen is that the 106 OTU sample is being eliminated.

Thanks

#4

Can you try it with fewer iterations?

#5

Hi Pat,

I tried this and received the same output. After 10+ hours it still hadn’t progressed passed the first sample.

Any advice appreciated

#6

Can you send the shared file to us at mothur.bugs@gmail.com and in the email provide the url to this thread?

Thanks
Pat

#7

Thanks for sending your files and reporting this issue. The slow down was caused by the way we were removing otus that had no members after the subsampling. I have modified how mothur removes the OTUs to greatly reduce the time required to eliminate them. You can download the updated version here, https://github.com/mothur/mothur/releases/tag/v1.42.1.

closed #8

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.