Different seqs in fasta and qual afer shhh


I just noticed something weird: I ran my sff file through sffinfo and trim.flows, and then shhh.flows. After it was done I wanted to run a non-mothur program on the fasta and qual files that shh produces (the per sample ones). However it crashed, and the reason seems to be that there are different sequences (or at least different names for sequences) in the files. Most of them are the same, but about 5% or so of the sequences in the fasta are not in the qual and vice versa.
Is that a bug or am I missing something? Not that it’s important as those files are not used in the standard mothur SOP I guess.




I am having a similar issue. I ran sff info–>trim.flows–>shhh.flows and when I went to use the trim.seqs command, mothur told me that the sequence name in my fasta file did not match the one in my qual file. Any one have any ideas?


If you do trim.flows/shhh.flows there’s no reason to use a qual file in trim.seqs. The output fasta/names files from shhh.flows only represent the unique sequences and won’t work with the earlier qual file.

Thank you, that helps.


I have a similar question, I go through the sff.info, trim.flows and shhh.flows without issues. After I trim.seqs, The seq names in the name files and fasta files no longer match. Also, the formatting of the fasta file is skewed. There is a large gap at the beginning before the first sequence. Here is how I run trim.seqs. Has anyone else run into this issue?

mothur > trim.seqs(fasta=filename.shhh.fasta, name=filename.shhh.names, oligos=454oligo.oligos, pdiffs=2, bdiffs=1, maxhomop=8, minlength=300, flip=T, processors=8)


Sounds weird - can you send the *shhh.fasta, *shhh.names, and oligos file to mothur.bugs@gmail.com? BTW, do you get anything out followign the SOP and using minlength=300 in trim.seqs?

Pat,Thanks for your reply. I played around last night and was able to do trim.seq for each sample individually, then merge the fasta, name files and group files to do the alignments, screen.seq and pre-clustering. The file I was trying to work with was pretty large (100 MB) and maybe that was the issue. I have a smaller file going through shhh.flow currently and will repeat the process to see if it was a glitch with my file.

Oh, BTW, the minlength=300 was a typo. it should have read minlength=200.

Thanks again for your time

Ok - still sounds weird - it should have worked how you ran it so we’d love to see the files if you can compress and email them to us or post them on the wiki for us to look at