compilation problems mothur v1.36.1

Dear mothur team,

I am using Ubuntu LTS 14.04 and wanted to install the recent version of mothur including boost. I followed all steps mentioned in the to
install boost (I installed it in my home folder) and to modify mothur’s makefile. In addition, I activated the line “CXXFLAGS += -mtune=native -march=native” for the linux installation and uncommented the corresponding line for the mac installation. When installing, I get the following error message:

fatal error: boost/iostreams/detail/config/dyn_link.hpp: No such file or directory
#include <boost/iostreams/detail/config/dyn_link.hpp>

The file actually exists under the directory given in the error message. Do I have to add soemthing to the makefile? Any other suggestions?

Thank you and best wishes,


A quick look at the makefile… although


are defined should they not also be passed to the compiler as an include directory for header files?


Just tested that on an Ubuntu 14.04.3 LTS VM and mothur did compile OK using boost 1.59 in a non default location.

Regarding the boost install I had to make a slight change to the b2 install to add a prefix otherwise it tried to copy files into a system directory I had no access to.

./ --prefix=/usr/local/src/boost/1.59
./b2 install   --prefix=/usr/local/src/boost/1.59


Hi Ian,

thanks a lot. That solved the problem.

Best wishes,