colons (:) in sequence header

Hi, maybe this is a naive question, but I thought I’d ask anyway to rule out any doubts.
I just started my 16S analysis on mothur v1.31.2 and, as a very first step I run summary.seqs on my fasta file:


All looks good, but at the end it displays this warning:

[WARNING]: your sequence names contained ‘:’. I changed them to ‘_’ to avoid problems in your downstream analysis.

The problem is that if I look into the fasta file with ‘less’ the colons are still there, nothing has changes, and no corrected version of the fasta file has been created. Also, if I run the summary.seqs command again in the same file, the same warning shows up, confirming that the colons are still there.
I’m tempted to just move on, but I’m afraid of potential problems down the line. So, should I worry about these colons and the fact that they don’t get replaced? Should I perhaps change them manually?

Thanks a lot!

If a fasta file is generated by the command the : should be turned into _. summary.seqs does not generate a new fasta file. if you look at the summary file the : should be changed to _ there.

Yes, the summary file does contain the sequence headers with ‘_’
And I tried to run trim.seqs, and the output fasta file actually has _, so I was worrying about nothing.

Thanks for your help!