chimera.uchime asks for cygwin1.dll using windows

chimera.uchime crashes with the following error message:

“This application has failed to start because cygwin1.dll was not found. Re-installing the application may fix the problem”

I am running 32bit v1.22.0 on windowsXP (could not get mothur to run on ubuntu 11.10).

mothur > chimera.uchime(fasta=current,name=current,group=current,processors=2)
Using 2.TCA.454Reads.trim.unique.filter.precluster.unique.fasta as input file for the fasta parameter.
Using 2.TCA.454Reads.groups as input file for the group parameter.
Using 2.TCA.454Reads.trim.unique.filter.precluster.names as input file for the name parameter.

uchime by Robert C. Edgar
This code is donated to the public domain.

Checking sequences from 2.TCA.454Reads.trim.unique.filter.precluster.unique.fasta ...
[ERROR]: Could not open 2.TCA.454Reads.trim.unique.filter.precluster.unique.uchime.chimeraerec

Then it crashes. Do I really need cygwin here? Can’t believe it. I actually have cygwin installed. Any ideas?


I actually get the same error message when just trying to execute the uchime.exe myself.

Version 1.22.1 is up on the wiki. Want to give it a try and see if it resolves the issue?

Hello! I am also having a problem with the cygwin1.dll being missing error. I am running the same batch file on two different computers, both computers having Windows7, but the error appears on Computer A but not on Computer B. At first I thought this might be an issue relating to the version of MOTHUR, but I tried the batch file on both 1.22 and 1.23, and either MOTHUR executable works for Computer A and neither works for Computer B (ie, Computer B always gives the “missing cygwin1.dll” error). I don’t know of any significant differences between the two computers - in fact, they were both clean installs of Windows7 as of last week - other than that Computer A is a desktop and Computer B is a laptop (Lenovo ThinkPad E420).

Any ideas?

I found a work-around! Not a fix, but a “good enough.”

Get Cygwin. Copy all of the .dll files and slap 'em into your folder with the MOTHUR executable (if you just put in cygwin1.dll then it will just ask for yet another .dll). I haven’t tested which subset of the .dll files is required, but by putting them all in there I was able to run chimera.uchime and finish my work. I am the first to admit that this is NOT an elegant solution.

I can’t help but wonder if the difference is related to the version of Windows7 on the two machines that I have been using - chimera.uchime is working on Enterprise but not on Professional. Thoughts? Better solutions?

Is the error message you are getting just when you run the chimera.uchime command or when you run any command in mothur?

I rebuilt the uchime.exe for Windows and have uploaded the new version to the wiki. Thanks for helping us spot this.