changing makefile to use 64 bit pointers

Please excuse the simplicity of this question.
I would like to take advantage of the multiple processors of my Mac running Mac OSX. Following the instructions for installation, I have changed the makefile to read “CC = g++ -arch x86_64”. Next, I have been instructed to re-run the “make” command. When I do so, I get the reply “make: ‘mothur’ is up to date”. I have the feeling that I have changed nothing. Can anyone lend a hand?

Congrats on being the first forum post!

First, run “make clean” and then run “make” again with your edited makefile. This should hopefully do the trick.

You can also add these flags for better CPU optimization:

if running Intel Mac : -O3 -fast -ftree-vectorize -ffast-math -arch x86_64
if running G5 : -O3 -fast -mcpu=G5 -mtune=G5 -ftree-vectorize -ffast-math
if running a G4 : -03 -fast -mcpu=G4 -mtune=G4 -ftree-vectorize -ffast-math

Turns on SSE and Altivec depending on your CPU. There is no need to explicitly use the -arch x86_64 as the Apple Xcode compiler auto detects this for you. But I could be wrong… even I state this explicitly. :slight_smile: I think -ffast-math is turned on by the -fast flag… but you never know when they may change things so I also add that as well.

Check these links out:

Hope this helps!