Buggy windows versions


I would just like to say, I have struggled with several problems using windows versions of mothur (the last three up to v1.27), from missing groups, sequences, name and group files don’t correspond, problems with removing chimercs etc. All problems where solved when using ubuntu instead. The same versions, but no errors. So, I guess if you would like to use the very good software mothur as a windows user, I highly recommend a dual boot with linux, or install linux virually (as I’m doing) using a client, such as Oracle Virtualbox. I’m not shure how many hours/days I have wasted trying to get thing to work, when only following the SOP that should be a walk in the park.


Hi Erik,
Sorry to hear you have had some struggles with our Windows versions. I would like to help resolve them. What commands were giving you trouble?


The commands I remember giving me problems were: After trim.seqs, strange name file. A big empty space in the beginning, and summary.seqs give error of not finding one ID in namefile.

chimera.perseus, Your name file contains xxx valid sequences, and your groupfile contains xxx, please correct. Tried to correct the name and sequence files manually, but chimera.perseus always gave me trouble if including a group file: our name file contains xxx valid sequences, and your groupfile contains xxx, please correct. Took the same data in linux (same mothur version 1.27, no problem at all starting on trim.seqs through chimera.perseus, including the group file.



Unfortunately, your comments are not helpful. About 50% of our users are using the windows version of mothur with few complaints that have anything to do with mothur itself. Your vague bug report does little to help us figure out the exact nature of your problem or improve the software. The general problem of a group file not matching the names and fasta files is typically because people use the wrong files at various steps. If you can provide us with the actual logfiles where you ran these commands in window with the resulting error, we’d be happy to diagnose the problem and fix it.

The problem with what you propose is that many of the virutal boxes are much slower than the windows option, which is slower than the mac/linux native versions (all of this is the same code). Furthermore, installing a dual boot and learning linux is not trivial and the whole effort is probably more than letting us help you and others figure out what is going wrong.

Take care,


I did the exact same thing on linux, starting with the same fasta and name file, using trim.seqs. Summary.seqs gave me an error in windows, but not in linux. The error in windows was xxxxxx is not in your name file. xxxxx was the first sequence in the fasta file, and when looking at the name file it was strange, with a big emty space (many emty lines) in the beginning of the document. The name file in linux was normal. Summary.seqs in linux gave no error. chimera.perseus in linux worked as it should with the group file, but I could not do it in windows, it would not accept a group file giving me errors. I know it is not trivial going into linux for most windows users, but it is increadably frustrating using days trying to solve simple problems that stops the whole analysis.

The commands are standards following the sop, no wrong files. Everything is comparable. It worked in linux, but not in windows with excact the same commands and identical files. Don’t know if windows versions can have anything to do with it, i’m running win8. I also had an earlier problem I mentioned here using win8, Solved! Groups missing in sequence and name files But that was gone with the upgrade from v1.26 to 1.27.

Since most users don’t complain, I guess maybe win8 is the problem. Have you testet mothur on win8, running through the sop?