Bug in classify.seqs

Hello, all.
I got a problem here. I have a fasta file and a tax file (its.fasta and its.tax) changed from the UNITE_public database. When I run the test.fas with classify.seqs, I keep getting a bug report as following:
mothur > classify.seqs(fasta=current,group=current,reference=its.fasta,taxonomy=its.tax)
Using test.fas as input file for the fasta parameter.
Using test.txt as input file for the group parameter.

Using 2 processors.
Generating search database… DONE.
It took 200 seconds generate search database.

Reading in the its.tax taxonomy… DONE.
Calculating template taxonomy tree… DONE.
Calculating template probabilities… [ERROR]: std::bad_alloc has occurred in the Bayesian class function Bayesian. Please contact Pat Schloss at mothur.bugs@gmail.com, and be sure to include the mothur.logFile with your inquiry.

I don’t know how to get through this trouble, please help me.
Best wishes


Hi Susie,
The error you are getting indicates you are running out of memory. Your template files have almost 300,000 sequences. I ran your files successfully with processors=1. It requires a little over 2G of RAM. The more processors you use the more memory is required. I would suggest running the command with processors=1.

Hi, Sarah.
Thanks for your help…I will try it again.

Susie :slight_smile:

Hi, Sarah,
I tried it again as you recommended, but the problem still came out. Does this have anything to do with the Mothur version which I use? I’m using mothur v.1.28.0 on windows XP.


How much RAM does your computer have?

The computer with windows XP system has 3G RAM. I finally find out that it works well on a Ubuntu system with only 2G RAM.