Apple silicon - need Rosetta?

Do I need to run Rosetta to run mothur on apple silicon?

Hmmm, I don’t think it should matter. Are you running into an issue?

Yes. I’ve recently moved to Apple silicon with a Mini M2 Pro. Rosetta is not installed my default and I haven’t needed it yet. When I run mothur, I get: “bad CPU type in executable: ./mothur”.

Many thanks for your help,


I just looked at my own computer and saw that I have an Apple silicon chip and am running mothur without any issue. I used this link from GitHub…

THere is a dialog that will open up saying “mothur cannot be opened because the developer cannot be verified”. To get around that, you can go to Finder and right click on the mothur icon (and the other executables in the directory). Then go to “Open with…” and then while holding down the command key, select terminal and click open on the dialog that opens.


Thanks Pat. I was already using that version but used your link anyway and tried again with the same result - “bad CPU type in executable: ./mothur”.

I then installed Rosetta 2 and tried again and then got the “mothur cannot be opened because the developer cannot be verified” message. I followed your instructions and mothur is now running. Activity monitor shows that mothur is running as an Intel app:

i.e it is using Rosetta 2.

Many thanks