All sequences lost after trim.seqs


I have been trying to figure out how to work with single reads. I came across a post in Mothur forum and tried to follow it. But when I am trying to trim the primer, all my sequences are thrown in the scrap file. Starting with single reads, I did something like this:-

  2. reverse.seqs(fasta=MC1.fasta)
  3. reverse.seqs(qfile=MC1.qual)
  4. make.fastq (for read and its reverse complement)
  5. make.contigs
  6. trim.seqs

My forward primer sequence that has a degenerate base is GTGCCAGCMGCCGCGGTAA
I created a reverse complement of this sequence, which is TTACCGCGGCKGCTGGCAC; and then prepared an oligo file written below for trim.seqs

(barcodes and adapters were already removed from my data by the sequencing platform)

I thought that all my sequences are thrown into scrap file possibly due to to the degenerate base. So, I tried to use both the bases “A” and “T” in place of “M”, but this too didn’t help me.

Kindly suggest a way to solve this.
Thanks and looking forward to hear you back.

Can you summary.seqs just before trim.seqs?

Hi Kmitchell,
Here it is-

mothur > summary.seqs()
Using stability.trim.contigs.fasta as input file for the fasta parameter.

Using 4 processors.

Start End NBases Ambigs Polymer NumSeqs
Minimum: 1 251 251 0 3 1
2.5%-tile: 1 251 251 0 3 16118
25%-tile: 1 251 251 0 4 161179
Median: 1 251 251 0 4 322357
75%-tile: 1 251 251 0 5 483535
97.5%-tile: 1 251 251 0 6 628595
Maximum: 1 251 251 14 115 644712
Mean: 1 251 251 0.00018613 4.20896

of Seqs: 644712

Here’s how I would recommend removing the primers from a single read dataset:

  1. - create fasta and quality files
  2. trim.seqs(fasta=current, quality=current, oligos=yourOligosFile, pdiffs=2) - remove primers from reads.

You can add in quality screening as well:

trim.seqs(fasta=current, quality=current, oligos=yourOligosFile, maxambig=0, maxhomop=8, pdiffs=2, qwindowaverage=35, qwindowsize=50)

Oligos File: