Screen.seqs result varying

I have a data set of 2x150 reads of 54 pairs of 16S v4 metagenomic sequences from NCBI sra of gastritis patients. When I previously ran the sequences through mothur, the screen.seqs after silva alignment removed sufficient number of sequences.

mothur > screen.seqs(fasta=current, count=current, start=2, end=13426)
Using Ulcer_Donors\stability.trim.contigs.count_table as input file for the count parameter.
Using Ulcer_Donors\stability.trim.contigs.unique.align as input file for the fasta parameter.

Using 4 processors.

It took 1278 secs to screen 3544746 sequences, removed 3505876.

Running command: remove.seqs(accnos=Ulcer_Donors\stability.trim.contigs.unique.bad.accnos.temp, count=Ulcer_Donors\stability.trim.contigs.count_table)
Removed 5370441 sequences from Ulcer_Donors\stability.trim.contigs.count_table.

Output File Names:


Output File Names:

It took 2067 secs to screen 3544746 sequences.

When I am running the sequences again with the same parameters and commands the result is different. Why is it so?
mothur > screen.seqs(fasta=current, count=current, start=1, end=13424)
Using Ulcer_Donors/stability.trim.contigs.good.count_table as input file for the count parameter.
Using Ulcer_Donors/stability.trim.contigs.good.unique.align as input file for the fasta parameter.

Using 64 processors.

It took 52 secs to screen 2417753 sequences, removed 15177.

Running command: remove.seqs(accnos=Ulcer_Donors/stability.trim.contigs.good.unique.bad.accnos.temp, count=Ulcer_Donors/stability.trim.contigs.good.count_table)
Removed 18156 sequences from Ulcer_Donors/stability.trim.contigs.good.count_table.

Output File Names:


Output File Names:

It took 72 secs to screen 2417753 sequences.

This time I had put in an extra screen.seqs (to put in minlength ) which reduced the number of sequences sufficiently after make.contigs (to put in maxee, deltaq, insert). Could it be because of this?

Hi there - it looks like your start and end positions in the screen.seqs command are different in the two runs. That’s likely the reason.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.