mothur

Remove.seqs Error: length is not in your count table

Hello, I’m a first year grad student trying to run Mothur for the first time. Skip to the end for the error, the rest is context. My lab runs it through MSI, the university’s supercomputer. I was accessing it through the Ubuntu Linux terminal installed on my Windows laptop. The reason I was using this terminal is that when I did a rotation I had to use software that was only for Mac/Linux. I haven’t used my Windows terminal yet; would it be easier if I tried to switch to that? Everyone in my lab runs Macs, so I thought it’d be easier for them to help me if I stayed with Linux because they’re more similar.

I was running batch mode, sending the batch script through slurm to MSI.

Here is my batch script:
set.dir(input=/home/hamil689/mcca1048/YNP_samples_spr21/data, output=/home/hamil689/mcca1048/YNP_samples_spr21/results)
set.logfile(name= ~/YNP_spr21_Mothur.log)
make.file(inputdir=/home/hamil689/mcca1048/YNP_samples_spr21/data, type=fastq, prefix=stability)
make.contigs(file=current,checkorient=t, pdiffs=4, trimoverlap=t, processors=24)
summary.seqs(fasta=current, processors=24)
screen.seqs(fasta=current, group=current, maxambig=0, maxlength=304)
unique.seqs()
count.seqs(name=current, group=current)
align.seqs(fasta=current, reference=/home/hamil689/mcca1048/References/silva.nr_v138.align, flip=f)
remove.seqs(accnos=current, fasta=current, count=current)
screen.seqs(fasta=current, count=current, start=1968, end=11550, maxhomop=8)
filter.seqs(fasta=current, vertical=T, trump=.)
unique.seqs(fasta=current, count=current)
pre.cluster(fasta=current, count=current, diffs=2)
chimera.vsearch(fasta=current, count=current, dereplicate=t)
remove.seqs(fasta=current, accnos=current)
classify.seqs(fasta=current, count=current, reference=/home/hamil689/mcca1048/References/silva.nr_v138.align, taxonomy=/home/hamil689/mcca1048/References/silva.nr_v138.tax, cutoff=80)
remove.lineage(fasta=current, count=current, taxonomy=current, taxon=Chloroplast-Mitochondria-unknown-Archaea-Eukaryota-Fungi)
cluster.split(fasta=current, count=current, taxonomy=current, splitmethod=classify, taxlevel=4, cutoff=0.03)
make.shared(list=current, count=current, label=0.03)
classify.otu(list=current, count=current, taxonomy=current, label=0.03)
phylotype(taxonomy=current)

Here is my slurm script:
#!/bin/bash -l
#SBATCH --time=2:00:00
#SBATCH --ntasks=24
#SBATCH --mem=16g
#SBATCH --tmp=16g
#SBATCH --mail-type=ALL
#SBATCH --mail-user=mcca1048@umn.edu
cd ~/home/hamil689/mcca1048/YNP_spr21_Mothur/data
/home/hamil689/shared/programs/mothur/mothur YNPMothurSOP.batch

TLDR: I have an error on the remove.seqs step that no one in the lab can understand, and I was wondering if someone here could help? From the logfile:
mothur > remove.seqs(accnos=current, fasta=current, count=current)
Using /home/hamil689/mcca1048/YNP_samples_spr21/results/stability.trim.contigs.bad.accnos as input file for the accnos parameter.
Using /home/hamil689/mcca1048/YNP_samples_spr21/results/stability.trim.contigs.good.count_table as input file for the count parameter.
Using /home/hamil689/mcca1048/YNP_samples_spr21/results/stability.trim.contigs.good.unique.align as input file for the fasta parameter.
Removed 0 sequences from your fasta file.
[ERROR]: <length is not in your count table. Please correct

Thanks in advance!

I am happy to help you sort this out.

Did mothur run out of disk space to write the output files on the server? This is the most common cause of unexplained errors. The *.align file can be very large and since the remove.seqs command did not remove any sequences, in essence you have 2 copies of the file.

stability.trim.contigs.good.unique.align & stability.trim.contigs.good.unique.pick.align

If the disk space is not an issue, can you send your input files and logfile to mothur.bugs@gmail.com?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.