read.dist not finding file


I’m currently working on a Debian Linux (Lenny) system, with oodles of memory. I have compiled mothur for 64 bit linux, but without mpi. I ran the dist.seqs command to generate a distance matrix, but when I try to read it back in using read.dist, I get a message saying that mothur is unable to open my distance file. I have checked numerous times, and the problem is not that I am mistyping the filename.

I have copied the relevant bits of the mothur logfile below. I tried to attach it to this message, but the extension “logfile” is not allowed. I tried changing to end in .txt, but apparently that is not allowed either.

Can you please let me know if I’m missing something obvious that is keeping me from being able to read my distance matrix back in? (In case, it’s relevant: the distance matrix file is very large: 751 Mb)

thank you,


Bits of the mothur logfile:

mothur v.1.13.0 Last updated: 9/17/2010 mothur > dist.seqs(fasta=hendrik_mothur_pick.fasta, output=lt)

mothur > dist.seqs(fasta=hendrik_mothur_pick.fasta, output=lt)
0 0
100 0
200 1
300 1
400 1
500 2
600 2
700 3
…and so on, until:
15000 1121
15100 1136
15124 1139

Output File Name:

It took 1139 to calculate the distances for 15125 sequences.

mothur > read.dist(phylip=hendrik_mothur_pick.phylip.dist , name=hendrik_mothur_pick.names, cutoff=0.25)
Unable to open hendrik_mothur_pick.phylip.dist

mothur > quit

Could you run the find command to see if mothur mistakenly put the file somewhere else?


The file is in the same directory I was running mothur from. (I have generated the file twice (once on one machine, once on another, where I have built the binary on each machine separately). In both cases, the dist file is created and is within my current working directly. The contents of the file look like I would expect when I glanced at it using the “less” command on Linux.



Could you try running the read.dist command with the full file name?


That seems to have done the trick:

read.dist(phylip=/home/btiwari/bioinf/projects/schaefer/mesocosm/mothur_sept2010/hendrik_mothur_pick.phylip.dist, name=hendrik_mothur_pick.names, cutoff=0.25)

I’m a bit concerned that the names file may or may not be seen here. I.e. if the dist file is not seen without the full path, is it possible that the names file is not seen either, but that it just doesn’t result in an error?



If mothur was unable to find the namesfile, and error message would be given as well. Are the .names and .dist file in the same folder?