mothur

Problem with cluster (No Run)

I am trying to make a cluster after a dist.seqs process but it not run, appear the text but not appear any number after 0.03. I am reapeating for thirth time but I can not obtain any result.
Mainly I made : make.file and make.contigs. screen.seqs and unique.seqs. Them, I join “name”.trim.contigs.good.names and “name”.contigs.good.groups through count.seqs. Align, precluster and chimera.vsearch. Filter.seqs with vertical=T. And, finally, the dist.seqs. After that I am trying cluster but it does not work. No appear any number after the 0.03 as I said

can you post your exact commands?

I’ve got the same one

I used those commands

make.file(inputdir=., type=fastq, prefix=LK)
make.contigs(file=LK.files, processors=24)
summary.seqs(fasta=LK.trim.contigs.fasta)
screen.seqs(fasta=LK.trim.contigs.fasta, group=LK.contigs.groups, maxambig=0, maxhomop=8, maxlength=466, minlength=439)
summary.seqs(fasta=current)
unique.seqs(fasta=LK.trim.contigs.good.fasta)
count.seqs(name=LK.trim.contigs.good.names, group=LK.contigs.good.groups)
align.seqs(fasta=LK.trim.contigs.good.unique.fasta, reference=silva.seed_v132.pcr.align)
summary.seqs(fasta=LK.trim.contigs.good.unique.align, count=LK.trim.contigs.good.count_table)
pre.cluster(fasta=LK.trim.contigs.good.unique.align, count=LK.trim.contigs.good.unique.count_table, diffs=3)
summary.seqs(fasta=LK.trim.contigs.good.unique.precluster.align, count=LK.trim.contigs.good.unique.precluster.count_table)
chimera.vsearch(fasta=LK.trim.contigs.good.unique.good.precluster.align, count=LK.trim.contigs.good.unique.precluster.count_table, dereplicate=t)
remove.seqs(fasta=LK.trim.contigs.good.unique.precluster.align, count=LK.trim.contigs.good.unique.precluster.count_table, accnos=LK.trim.contigs.good.unique.precluster.denovo.vsearch.accnos)
summary.seqs(fasta=LK.trim.contigs.good.unique.precluster.pick.align, count=LK.trim.contigs.good.unique.precluster.pick.count_table)
filter.seqs(fasta=LK.trim.contigs.good.unique.precluster.pick.align, vertical=T)

Change name to LK1

dist.seqs(fasta=LK1.fasta)
cluster(column=LK1.dist, count=LK1.count_table)

I’m not sure how much it should matter, but you need a filter.seqs(vertical=T, trump=.) and a unique.seqs() commands after running align.seqs. You can then get rid of the final filter.seqs as you have it. Can you replace the dist.seqs and cluster commands with cluster.split as described in the MiSeq SOP?

I’ve replaced the commands and the same error is happening

Can you tell us what the error message is? Sorry, I’m still not exactly clear what’s going wrong.

when I’ve applied cluster after dist.seqs nothing appeared on screen, only a 0.03 number line as if it were working but isn’t because after many time a network connection error message come up.

when i’ve applied just cluster.split it seems the command is working with a normal running, however after 40, 50 minutes the same message of network connection error appear and run is aborted…

I’m trying make cluster.split in 2 step as Westcott advised in “Command cluster_issue” thread

Are you using a remote computer in an interactive session? I think you should probably switch to running a bash script and your server’s job manager (ie slurm) or at least use screen to detach so the job will continue running even if you are disconnected.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.